FANDOM


Setting up your Project MachineEdit

  • Map your Archive/Project drive where your projects will be located. This should be the same project drive your farm uses
    • ( ex. P: )

Preparing a ProjectEdit

  • 100% of your files MUST be accessed on a network or shared drive using the same path as the farm machines.
    • you can Archive your project or manually upload all your assets to the network's project folder. ( P:\MyProject\ )


  1. Run your local machine's version of AfterFX.exe
  2. Open your project
  3. Varify all assets in the Project are on the network AND are available through mapped drives.
    • NO files can be local on your machine.
    • Files routed through file:\\MyServer\MyProject\Assets\ will not work properly
  4. Remove ALL Photoshop Effects from your Layers! (ex. Layer Styles)
  5. Add your renders to your local Render Queue
    • Set Output to: any mapped drive location, usually a project folder.
  6. Save Project (the project MUST be saved) (also .AEPX will not work! use .aep)

Sending a Project to the Render FarmEdit

Single-Machine Render Edit

  1. File-> Collect Files
  2. Set the dialog as follows
    • Set Collect Source Files: NONE (Project Only)
    • Uncheck all but the bottom box
    • Set the number of machines you want to render (don't hog the machines if others need them too)
    • Click Collect
  3. In the dialog Select X:\RenderFarm\MyProject_01
    • Make sure the Folder name is unique to this render by iterating the number.
    • You are done! You can check your render status following the instructions just below.



Multi-Machine Render Edit

This type of render is used when you are crashing AE renders alot or you have an extraordinarily long render you need completed quickly.

  1. delete the previos TGA target footage
  2. Run your local machine's AfterFX.exe
  3. Open your Project
  4. Varify all assets in the Project are on the network AND are available through mapped drives.
    • NO files can be local on your machine.
    • Files routed through not work properly
  5. Varify that you are not using plugins that did not come with AE
    • keylight and CC plugins are ok
  6. Add your renders to your local Render Queue
    • Set your Output to your mapped drive location: usually a renderfarm folder on your X: drive
  7. Multi-Machine Setup
    • Set Render Settings: dropdown-> Multi-Machine Settings (uncheck use storage overflow and check skip existing files)
    • Set Output Module: Dropdown-> Multi-Machine Sequence
    • Modify the Output Module: Multi-Machine Sequence
      • Change Format to Targa or PNG Sequence (I would edit the default setting: Edit->Templates->Output Module->(settings Name dropdown) Multi-Machine Sequence->edit button)
    • If you have alpha channels
      • Channels: RGB
      • Depth: Millionsof Colors+
      • Format Options->32 bits/pixel
  8. Save Project
  9. File-> Collect Files
  10. Set the dialog as follows
    • Set Collect Source Files: NONE (Project Only)
    • Uncheck all but the bottom box
    • Set the number of machines you want to render (don't hog the machines if others need them too)
    • Click Collect
  11. In the dialog Select X:\RenderFarm
    • Make sure the Folder name is unique to this render by iterating the number.
    • you are done!

Checking a Render Edit

  1. Navigate to X:RenderFarm\MyProject_01\MyProject_01.htm

CleanupEdit

Clean up old render info:

  • Clean up the watch folder X:/RenderFarm/ when there are more than 12 folders present.
  • It's not too important to save these, so deleting them is safe if you know the project has rendered successfully.

Resolve a failed network render Edit

If any of the render engines can't render a project, all render engines will stop rendering the project and the network render will fail. To resolve a failed network render, work through the following steps.

1. Open the HTML log file to determine the cause of the problem. Edit

The HTML log file ([ filename ]_00.htm) is located in the Collect Files folder and contains project render information. Open the HTML log file and click the link for the render item, listed below Render Item, to determine the cause of the problem. Click the link for the render engine, listed below Render Machines, for errors and additional details.

If missing source files caused the network render to fail, complete the following procedure:

a. Manually copy missing source files to the (Footage) folder in the Collect Files folder.

b. Open the copied project in the Collect Files folder.

c. In the Project window, select the source file you copied, and choose File > Replace Footage > File.

d. Navigate to the source file in the (Footage) folder, and then click Open.

2. Create a new Render Control File (RCF). Edit

If a network render fails, the RCF is invalidated. To resume the network render, you must create a new RCF to replace the invalid one.

To create a new RCF:

a. Turn off all render engines. (If render engines are on and running the Watch Folder command, they automatically resume rendering after you create a new RCF file, and the problem will recur.)

b. In After Effects, open the project in the Collect File folder.

c. Choose File > Collect Files.

d. Choose None (Project Only) from the Collect Source Files pop-up menu.

e. Select Enable "Watch Folder" Render and deselect Change Render Output To. All files will be rendered to the same output folder that you created when you first collected files.

f. Click Collect, name the folder, and save it to the original Collect Files folder.

g. Close the project.

h. If you manually copied source files to the Collect Files folder (step 9), make sure that the path names for all source files refer to the (Footage) folder in the Collect Files folder. To check path names, open the project file that you just created, and drag the bottom-right corner of the Project window to view the File Path column.